fptl.net
当前位置:首页 >> jquEry.min.js与jquEry.js冲突吗 >>

jquEry.min.js与jquEry.js冲突吗

不冲突,按先后加载顺序使用的,但是没必要两个都引入啊,带min的是不带min的压缩版,压缩版不能看代码,因为很乱,不带min的可以看源码用于研究用,正常工作中引入压缩版的就好了,因为文件小加载快省流量啊

$符号的让渡问题,楼上的做法是正确的,不过还有种做法,就是另外封装$符号,在你的代码的最外层加上: (function($){ 这里放你原来的代码,就可以了 })(jQuery)

只有看版本信息。 如果jQuery.js 是2.0+ 的版本,见不会支持IE6/7/8 但是一个HTML文件中引入2个JQuery文件,过于浪费资源。

min是压缩版,去除了注释和空格,主要是生产环境中使用,不带min是带有注释和空格的,方便阅读源码

var jq = jQuery.noConflict(true); 给其中一个定义别名,就可以了 这个是给1.82的定义了,别名,在使用这个类库的地方将$换成jq就可以了

同一页面同时引用2个jquery文件以后$就会冲突.解决方法也很简单..改名字..jquery 有个方法叫noConflict();可以给jquery起名字.. 在同一个页面中加载多个不同的jQuery版本 var jQuery_New = $.noConflict(true); var jQuery_1_6_2 = $.noConflict...

多jquery或者与其他js框架混用时,需要在某一个jquery中插入js语句xxx=$,xxx为自定义字符串。

不用修改: 在使用自己的js时加上 jQuery.noConflict(); 这样就可以使用自己js中的$了,当然在之后jQuery中的的$就得使用jQuery代替了

1.区别: jquery官网提供2种jQuery的下载,一种是jquery.js另一种是jquery.min.js 文件名不一定完全相同,但通常情况下: jquery.js是完整的未压缩的jQuery库,文件比较大,一般用于阅读学习源码或修改源码,一般不用于线上项目。 jquery.min.js...

这是两个版本的jq库,用一个就可以了,你引入两个是什么意思?

网站首页 | 网站地图
All rights reserved Powered by www.fptl.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com